ArboristSite.com Sponsors
 
 


  1. Please see this post Click Here Please ask questions if you have them!! I hope this is going to be great for us all.
    Dismiss Notice

7900 Leaking

Discussion in 'Chainsaw' started by Jesse Benson, Mar 9, 2009.

  1. Jesse Benson

    Jesse Benson ArboristSite Lurker

    Joined:
    May 29, 2008
    Messages:
    31
    Likes Received:
    11
    Location:
    WI
    I have a 7900 that is about a month old. Once in a while it leaks gas. It looks like it comes from the cap. The o-ring has no knicks, I have tried snugging it and really tightening it. It will only do this once in a while. Does anyone else have this problem. I know this is a simple problem, but I have tried the things that make sense with no prevail. What do ya think.:mad:
     
  2. computeruser

    computeruser Addicted to ArboristSite

    Joined:
    Jan 1, 2005
    Messages:
    6,184
    Likes Received:
    2,039
    Location:
    East Lansing, MI
    I had one that did that. Changed the O-ring that looked "perfect" and it stopped.
     
  3. Jesse Benson

    Jesse Benson ArboristSite Lurker

    Joined:
    May 29, 2008
    Messages:
    31
    Likes Received:
    11
    Location:
    WI
    Hey, thanks puter guy. I guess I will be off to get an o-ring. I hate when you have problems that show no obvious defects.
     
  4. JT78

    JT78 ArboristSite Guru

    Joined:
    Aug 13, 2007
    Messages:
    776
    Likes Received:
    93
    Location:
    Burlington,NC
    I have had this problem with my 7900 and I took the O ring off and cleaned everything really well no more problems I think my issue was just a little saw dust.
     

Share This Page