Welcome to ArboristSite.com! Log in or Sign up to interact with the ArboristSite community.

ArboristSite.com Sponsors
 
 


  1. Please see this post Click Here Please ask questions if you have them!! I hope this is going to be great for us all.
    Dismiss Notice

BC1400 Infeed roller gap/spread. Tightening issue.

Discussion in 'Large Equipment' started by burtonbc1400, Oct 10, 2018.

  1. burtonbc1400

    burtonbc1400 New Member

    Joined:
    Oct 10, 2018
    Messages:
    1
    Likes Received:
    0
    Location:
    Enderby, BC
    Hi, This is my first post.
    I recently bought a Vermeer BC1400, my first chipper. It sat around for a while before I bought it and I had to solve some problems to get it running and chipping. It does chip now!
    But, I brought it to a job and was chipping some pretty big stems, probably max capacity 14".

    Now, the (vertical) infeed rollers have about a 3" gap between them and I can't get them to spring together again.

    I tightened the springs to max tightness, and cleaned under the infeed rollers as best as I could.

    The machine still chips OK, but I would prefer the infeed rollers to be closed so they can grab small branches, and just to keep it in proper order.

    Can anyone help me with advice or troubleshooting tips? How do I tighten these rollers together again?

    Thanks!
     
  2. Eq Broker

    Eq Broker GlobalEquip

    Joined:
    May 5, 2009
    Messages:
    533
    Likes Received:
    93
    Location:
    Marietta
    The springs might be worn and it's time for new ones.

    Hope this helps!

    Dave
    Global Equipment Exporters
    770-420-6400
     

Share This Page