• Please be aware that we have recently gotten a wave of users that, when researched, are found to be from Nigeria. They are trying to sell products and asking to be paid through Zelle or Venmo leaving users with no recourse if they don't ship the product. If you suspect this activity please contact admin and we will research their information to verify their location.

ArboristSite.com Sponsors
Peak Industries


Husqvarna 55 rancher will not fire

RAM2940

RAM2940

ArboristSite Lurker
Joined
Apr 14, 2017
Messages
17
Age
61
Location
Virginia
First post and need help with saw. Purchased saw not running, previous owner said while cutting saw just quit running and would not restart. He installed new coil, carb and spark plug. I got saw, checked spark, not good, adjusted coil and installed correct ngk bpmr7a plug, have consistant spark. Checked compression, 6 pulls about 160. put either in no fire, not even and attempt to fire. Removed muffler saw minor scoring and burn marks past ring, put penitrating oil in upper cylinder and rolled piston up, saw bubbles blowing out around piston. Also has a sound like air whistling by. Is this a sign that it needs new piston and cylinder.
Thanks for any help.
 
romad10

romad10

Recon Observe Mark And Destroy
Joined
Aug 3, 2009
Messages
334
Location
Indiana
No. Your fine.160psi u r good. Check on the pulse line silicone sleeve . if the crack at all or hard dry rotted, the cylinder will not send a pulse to the carb to pump the fuel.


Sent from my VS995 using Tapatalk
 
romad10

romad10

Recon Observe Mark And Destroy
Joined
Aug 3, 2009
Messages
334
Location
Indiana
55 is a great saw and super easy to work on. One of easiest saws ever made to work on. The other thing to ceck initially is fuel line. If you have not replaced it, replace it. And fuel filter. The fuel lines on those saws crack between the crankcase and fuel tank badly. You cant see it.... Those are very easy very inexpensive things to check.

Sent from my VS995 using Tapatalk
 
NIP Group
romad10

romad10

Recon Observe Mark And Destroy
Joined
Aug 3, 2009
Messages
334
Location
Indiana
You mentioned that you put new carb on it? You didnt put the gasket between the vmcarb and seperator plate on upside down did you? There is a pulse hole in it that must line up with hole in seperator plate and carb. Part number 501 77 00-02 as shown in picture. The pulse line silicone ring is part number 505 31 07-51 as shown in picture.

Sent from my VS995 using Tapatalk
 
RAM2940

RAM2940

ArboristSite Lurker
Joined
Apr 14, 2017
Messages
17
Age
61
Location
Virginia
When pulling to start, plug did seem to get wet and smell like fuel, what suprises me is that it will not even attempt to fire on the either. checked the pulse tube and that looked good.
 
romad10

romad10

Recon Observe Mark And Destroy
Joined
Aug 3, 2009
Messages
334
Location
Indiana
Is it an oem carb or chinese? Part number of carb? If its wet too fast it wont fire. Did you put a short piece of hose on the carb by itself and attempt to blow into carb or suck out of carb. If you can do either, the needle is stuck open and will flood the engine.

Sent from my VS995 using Tapatalk
 
RAM2940

RAM2940

ArboristSite Lurker
Joined
Apr 14, 2017
Messages
17
Age
61
Location
Virginia
Just went out and checked gasket on carb was in correct position, it has a zama carb on now but i was given the orginal carb at purchase. have not tried blowing through carb, will give that a try, Im just a novice learning as i go, but i thought spraying a little either in spark plug hole would bypass any carb issues, just to see if it would fire.
 
romad10

romad10

Recon Observe Mark And Destroy
Joined
Aug 3, 2009
Messages
334
Location
Indiana
No ether! Booom.... Dont do that. What is your gap set to berween magnet on flywheel and coil pickups?

Sent from my VS995 using Tapatalk
 
romad10

romad10

Recon Observe Mark And Destroy
Joined
Aug 3, 2009
Messages
334
Location
Indiana
If you take plug out and pull over really fast does fuel sprsy out of sparkplug hole? When i say spray, as in droplets, not mist.

Sent from my VS995 using Tapatalk
 
RAM2940

RAM2940

ArboristSite Lurker
Joined
Apr 14, 2017
Messages
17
Age
61
Location
Virginia
Not a pop with a wet plug?
broken keyway on flywheel ?
Sounds exactly like my ECHO blower and my friends Husky 55 that I fixed.
Its just like pulling saw with no fuel, when you say broken keyway, I can rotate or pull starter cord with plug out and watch piston go up and down
 
romad10

romad10

Recon Observe Mark And Destroy
Joined
Aug 3, 2009
Messages
334
Location
Indiana
Keyway broken off will allow spark, just at wrong time. Because flywheel is in wrong spot on crank

Sent from my VS995 using Tapatalk
 
RAM2940

RAM2940

ArboristSite Lurker
Joined
Apr 14, 2017
Messages
17
Age
61
Location
Virginia
Is it an oem carb or chinese? Part number of carb? If its wet too fast it wont fire. Did you put a short piece of hose on the carb by itself and attempt to blow into carb or suck out of carb. If you can do either, the needle is stuck open and will flood the engine.

Sent from my VS995 using Tapatalk
With carb off was not able to blow through carb.
 
Top