• Please be aware that we have recently gotten a wave of users that, when researched, are found to be from Nigeria. They are trying to sell products and asking to be paid through Zelle or Venmo leaving users with no recourse if they don't ship the product. If you suspect this activity please contact admin and we will research their information to verify their location.

ArboristSite.com Sponsors
Peak Industries


SUCCESS!!! Just repaired Stihl 045/056 Bosch electronic ignition!!!!!

PogoInTheWoods

PogoInTheWoods

Don't forget about the alligators...
Joined
Dec 13, 2009
Messages
5,741
Location
Reportedly in the Area
I see wires cut off at the filling in the center section and I’m not sure it’s saveable,
Some patient potting removal and careful soldering could salvage that.

I did the fix as well, and i think I have the right capacitor.
You need a capacitor within a limited range of specs. They aren't a common capacitor. Several variants that have proven to work have been posted including the ones in the pic below. Someone posted a good link several months ago from a source in Taiwan with a limited quantity of the Philips chips. I ordered a couple and received them in six days. The rest were gone within a couple of days once the availability became known.

image.jpg
 
Dolmar88

Dolmar88

ArboristSite Lurker
Joined
Dec 25, 2019
Messages
26
Age
31
Location
Amsterdam
Some patient potting removal and careful soldering could salvage that.


You need a capacitor within a limited range of specs. They aren't a common capacitor. Several variants that have proven to work have been posted including the ones in the pic below. Someone posted a good link several months ago from a source in Taiwan with a limited quantity of the Philips chips. I ordered a couple and received them in six days. The rest were gone within a couple of days once the availability became known.

Thanks for the information but witch one did you order? Because I used that same picture to find the right ones I thought. So now I don’t know anymore haha.
Thanks I hope you can help me.
 
Dolmar88

Dolmar88

ArboristSite Lurker
Joined
Dec 25, 2019
Messages
26
Age
31
Location
Amsterdam
I don’t get it because I have a nice blue spark but it doesn’t work. Now I ordered the ones foggysail sees the are good so I hope it will work than greetings
 
Dolmar88

Dolmar88

ArboristSite Lurker
Joined
Dec 25, 2019
Messages
26
Age
31
Location
Amsterdam
The values of the capacitors pictured should be adhered to for the desired results.
Oke so there the good ones? But way doesn’t the saw stay running? Yesterday I started it again and than played with the throttle than it runs for a little bit more but than fals dead again and can’t start it again!
So I have no idea anymore haha
I hope you van help me
Thanks for the help anyway
 
PogoInTheWoods

PogoInTheWoods

Don't forget about the alligators...
Joined
Dec 13, 2009
Messages
5,741
Location
Reportedly in the Area
Carb adjustments maybe? Try it again. If it starts and attempts to run but dies, check for spark. If there's still good spark and the timing is close, I'd say you're looking at a fuel delivery problem..., provided you also have good compression and aren't overlooking a scored piston/cylinder or something else inhibiting combustion -- like a massive air leak.
 
Dolmar88

Dolmar88

ArboristSite Lurker
Joined
Dec 25, 2019
Messages
26
Age
31
Location
Amsterdam
Yeah I will try that with the carb,
Al the other stuff is still good.
Compression on 150ps
Piston is like new,
So I hope there’s something with the feul.
I will check idt out en let you know
 
Dolmar88

Dolmar88

ArboristSite Lurker
Joined
Dec 25, 2019
Messages
26
Age
31
Location
Amsterdam
I tried adjusting of the ignition and checked if there was nice blue spark.

I have old the time nice blue spark, and the plug is wet al the time.
Its runs today 1sec and after that nothing anymore.
I think I will wait on the new capacitor, because I don’t know anymore.
 
FSE_Dolmar

FSE_Dolmar

New Member
Joined
Jul 9, 2020
Messages
1
Age
48
Location
MI
Top