40 ton County line Splitter from TSC....owner feedback??

JRHAWK9

JRHAWK9

ArboristSite Operative
Joined
May 8, 2010
Messages
436
Location
Lake Delton, WI
I wonder where that 3800psi is coming from. Maybe the absolute most the cylinder can handle?


Most gear pumps on splitters are 3000psi max.

Typical pressure relief is in the 2200-2400psi area.

That makes for about 23-25 tons.

Ratings like that need to be regulated. It's just as bad as the "6hp" vacuum cleaners somehow working on a 15amp max 120v line, max of roughly 2hp.

I just threw a gauge on my CL 40 ton inline between the pump and control valve. It maxed my 3,000psi gauge out at ~3,200 psi and was still climbing when I let off. I should probably back off on the relief some. LOL
 

sb47

Addicted to ArboristSite
Joined
Jun 14, 2011
Messages
5,847
Location
Texas
My current Speeco has the same/similar foot plate with the same little welded on "spikes" and I've lived with them like that for this long I can make due. I have had crooked cut logs though want to walk up, I just repositioned and carried on. I extended my breather so when I towed it on our hilled lawn with the fill side down, it didn't spill all over.
With faster cycle times that wood kicks out quick and kicks like a mule. That little flat bar I welded on mine really works by keeping wood from slipping off the edge.
 
ChoppyChoppy

ChoppyChoppy

Tree Freak
Joined
Jun 17, 2013
Messages
10,597
Location
AK
With faster cycle times that wood kicks out quick and kicks like a mule. That little flat bar I welded on mine really works by keeping wood from slipping off the edge.
I've had frozen wood go flying a few times. Sometimes flys clear out the splitting chamber and several feet up the conveyor. Got hit in the mouth once too.
Does split nice and clean when froze.
 
JRHAWK9

JRHAWK9

ArboristSite Operative
Joined
May 8, 2010
Messages
436
Location
Lake Delton, WI
FYI, upgrading the OEM filter/filter housing to something that is rated to flow 25GPM+ will gain you 0.3sec in cycle time.


That OEM filter setup was a restriction for the 25GPM pump. I gained 2-3 tenths on my cycle time...more than likely all on the return stroke due to the ability for the pump to pump it through the filter faster. It basically has a 9sec cycle time now. If I run it at 2,640 rpm's, which is about half throttle, I see the same cycle time as my Speeco has....a little under 13sec.
 

Attachments

  • IMG_20210213_212703452.jpg
    IMG_20210213_212703452.jpg
    2.7 MB · Views: 9
  • IMG_20210213_210405932.jpg
    IMG_20210213_210405932.jpg
    2.4 MB · Views: 8
  • IMG_20210213_210334980.jpg
    IMG_20210213_210334980.jpg
    2.5 MB · Views: 11
JRHAWK9

JRHAWK9

ArboristSite Operative
Joined
May 8, 2010
Messages
436
Location
Lake Delton, WI
The whole reason I did the swap was I could not find a replacement filter rated to flow 25GPM that would fit the OEM head. I'm pretty sure the OEM filter did not either. When the oil was cold I'm guessing there was some bypassing of the filter going on...maybe even when warm too.
 

Latest posts

Top