ArboristSite.com Sponsors


Echo 452VL

a. palmer jr.

a. palmer jr.

Tree Freak
Joined
Apr 8, 2007
Messages
13,989
Location
Southern Indiana
Received an Echo 452vl the other day and can't get it running. It seems to have great compression, has spark, I cleaned and kitted the carburetor and checked the fuel lines and filter, they seemed okay. Pull the choke and it hits four or five times like normal, but when you push the choke in it may pop once and that's it. I've tried all different adjustments on the H and L screws but to no avail. Think a pressure/vac test is needed or not? I've put off doing that because it's a little different than the Stihls I normally work on and I'll have to rig up the equipment..
 
HarleyT

HarleyT

A-Hole!!
Joined
Dec 6, 2014
Messages
18,770
Received an Echo 452vl the other day and can't get it running. It seems to have great compression, has spark, I cleaned and kitted the carburetor and checked the fuel lines and filter, they seemed okay. Pull the choke and it hits four or five times like normal, but when you push the choke in it may pop once and that's it. I've tried all different adjustments on the H and L screws but to no avail. Think a pressure/vac test is needed or not? I've put off doing that because it's a little different than the Stihls I normally work on and I'll have to rig up the equipment..
Clean and adjust the points.
 
a. palmer jr.

a. palmer jr.

Tree Freak
Joined
Apr 8, 2007
Messages
13,989
Location
Southern Indiana
Ok, fresh fuel didn't help. Thought maybe muffler stopped up so removed it and it wasn't but did have a lot of oil in it. I'm soaking the muffler right now. I'll check the fuel lines again since it's easy, might buy a new carb for it or maybe check the seals. I'm sure the one under the flywheel is okay but don't know about the sprocket side seal...
 
Top