ArboristSite.com Sponsors


MS271 port cover came off?

benmyers

benmyers

ArboristSite Operative
Joined
Aug 15, 2009
Messages
316
Location
Indiana
I rebuilt a 271 for a buddy a while back. Not my first choice in saws but it could be saved so we fixed it.

He ran it for quite a while then it stopped and wouldn’t start. I started taking it apart and noticed the port cover has come completely off.

Has anyone seen this? Could it be sealed and maybe peened to stay on?
I considered trying to tig weld it but I don’t think it’ll go well. Curious what the pros say around here. Pics attached.
 

Attachments

  • 8EF9B1B2-2456-4A62-B364-CB97EB2008B6.jpeg
    8EF9B1B2-2456-4A62-B364-CB97EB2008B6.jpeg
    2.7 MB · Views: 22
  • F0A7AACF-834C-4A2D-A6B6-7CE57196F37B.jpeg
    F0A7AACF-834C-4A2D-A6B6-7CE57196F37B.jpeg
    2.5 MB · Views: 22
  • F0C27EC2-5C28-482C-A45E-D3C4FAE20D9D.jpeg
    F0C27EC2-5C28-482C-A45E-D3C4FAE20D9D.jpeg
    2.8 MB · Views: 22
46 Poulan

46 Poulan

Addicted to ArboristSite
Joined
Feb 20, 2015
Messages
1,499
Location
albany
Saw the same last week at my workplace .Stihl saw--not sure of model. Port cover came unglued--may have been over heated. Seems pretty cheap,chinse way to build it. We replaced the cyl...
 
benmyers

benmyers

ArboristSite Operative
Joined
Aug 15, 2009
Messages
316
Location
Indiana
Interesting. I will search around to see if I can find the thread. Can anyone confirm these are glued from the factory? I definitely will not be spending the money on a new cylinder. These saws are junk in my opinion.
 
67L36Driver

67L36Driver

Tree Freak
Joined
Nov 1, 2010
Messages
14,400
Location
St. Joseph, MO
Interesting. I will search around to see if I can find the thread. Can anyone confirm these are glued from the factory? I definitely will not be spending the money on a new cylinder. These saws are junk in my opinion.

+1. [emoji34]

I have a MS 311 here that the transfer cover leaks. Took forever to find it. [emoji2959]
 
frank_

frank_

ArboristSite Guru
Joined
Nov 5, 2019
Messages
963
Location
b/ham uk
Frank,
do you have a link? I assume it holds up to high heat? I figured maybe some high temp epoxy may work as well.
it was pu bonding sealant from ebay mate, quite expensive and goes off in the tube when opened
i tried all sorts to stop it going off for a later job, but always ended up binning it
 
Top