ArboristSite.com Sponsors


MS391 revs up when you let off the trigger

RED-85-Z51

RED-85-Z51

Addicted to ArboristSite
Joined
Aug 11, 2006
Messages
4,207
Location
USA
Haven't dug into it yet, just came in...but ive never seen a saw that holds wide open smooth but when you let off the trigger it revs up noticeably...like a big air leak only on idle.

Really dislike these saws, 311 and 391.

Anyone wager a guess what i find?

Sent from my SM-G996U using Tapatalk
 
RED-85-Z51

RED-85-Z51

Addicted to ArboristSite
Joined
Aug 11, 2006
Messages
4,207
Location
USA
Gave it a once over, clean saw overall, one of the 3 manifold to cylinder bolts is gone, but i don't think that would make it so dramatic. Hadnt thought of the side covers, thats not something I've run into as of yet. I was looking for a good way to seal off the intake to pressure test the motor, looks like a normal rubber behind the carb will do it and still give me access to the impulse and boot.

Sent from my SM-G996U using Tapatalk
 
RED-85-Z51

RED-85-Z51

Addicted to ArboristSite
Joined
Aug 11, 2006
Messages
4,207
Location
USA
Found that 3rd screw...
d66273c16e95f17cb7f5f86f3f37cdc0.jpg


Sent from my SM-G996U using Tapatalk
 
RED-85-Z51

RED-85-Z51

Addicted to ArboristSite
Joined
Aug 11, 2006
Messages
4,207
Location
USA
Im shocked it ran so well, massive vac leak and never leaned out.

Sent from my SM-G996U using Tapatalk
 
RED-85-Z51

RED-85-Z51

Addicted to ArboristSite
Joined
Aug 11, 2006
Messages
4,207
Location
USA
How’s the piston looking
It got hot but no scoring, he runs red armor oil and E-0 gas. He was stumping and about midway thru it layed over, he finished the stump and when he let off it died and no restart.

Sent from my SM-G996U using Tapatalk
 
Top