Need help with Husco hydraulic control valves on Holan bucket truck

Help Support ArboristSite:

hellpcangel911

hellpcangel911

ArboristSite Lurker
Joined
Jul 23, 2013
Messages
12
Location
North East
Hi All,
I purchased a '99 Freightliner truck with a 55' Holan bucket. The truck has been well serviced and cared for by a large electrical contractor, it has a joystick and three extras hydraulically actuated jib, winch and bucket tilt.
I'm running into an issue with the controls for the three extras. All of the other controls work both from the joystick and lower controls. I have lower controls for the winch (which works) but not for the bucket tilt and jib actuation).

Since its a Holan, obviously theres limited support or info available but I'm hoping someone here has advise where to look.

The truck has one large PTO Muncie pump, no other aux pumps and no electronics. The upper Husco control valve 6480-142-2 (joystick) has a hose running off of it to the 3 spool mini valve (6060-59-201) which controls the winch and jib.
Theres a line coming out of the unused 3rd spool connecting to a block and going to the bucket tilt spool.

Since the winch works from the lower controls but not the upper I assume theres an issue with not getting pressure from the main control valve into the 3 spool mini. When I operate any of these three controls I can feel a slight pulsing in the hydraulic line connected to each unit, but not enough to work anything.

Any suggestions on what to check or where to start would be greatly appreciated.

Thanks!
 

Attachments

  • IMG-2055.JPG
    IMG-2055.JPG
    2.4 MB · Views: 6
  • IMG-2060.JPG
    IMG-2060.JPG
    2.2 MB · Views: 5
  • IMG-2064.JPG
    IMG-2064.JPG
    2.9 MB · Views: 5
  • IMG-2065.JPG
    IMG-2065.JPG
    2.3 MB · Views: 4
  • IMG-2067.JPG
    IMG-2067.JPG
    2.2 MB · Views: 4
  • IMG-2070.JPG
    IMG-2070.JPG
    2.4 MB · Views: 5
  • IMG-2071.JPG
    IMG-2071.JPG
    2.4 MB · Views: 5
hellpcangel911

hellpcangel911

ArboristSite Lurker
Joined
Jul 23, 2013
Messages
12
Location
North East
FIXED
Should anyone stumble upon this in the future, my issue was with the joystick throttle linkage. When the throttle is depressed these three auxiliary functions are locked out but the rest of the joystick functions. The return spring was broken off and the linkage wasnt lubricated so the spool springs were not strong enough to return it to center.
 

Latest posts

Top