ArboristSite.com Sponsors


Partner Chainsaw Thread

Modifiedmark

Modifiedmark

Tree Freak
Joined
Dec 2, 2007
Messages
18,625
Location
NW Indiana
Those
Rifa modules are more often then not the reason for no spark on the Ignitron systems. The good thing is they can be replaced with a Nova type module and work great. The Rifa is internally grounded and the Nova externally but its simple to add a ground wire to it. I have a P100 running the Nova module.

The previous owner had tried to swap a Husky coil to it but you have to watch to make sure the laminates match the contour of the flywheel. In this case he used a smaller Husky coil and it would not work because the P100 flywheel was much bigger dia. On the 85cc-100cc saws you need a coil from the larger Husky or there are tons of coils for the bigger Partner cutoff saws out there. Just stay away from the green coils that are rev limited.

The Husky 55 etc coil is a nice fit on the smaller Partners but the plug wire is routed out the side instead of from the top. It will still work but I think I had to shorten the plug wire on it.
 
leecopland

leecopland

Addicted to ArboristSite
Joined
Oct 30, 2011
Messages
1,253
Location
huntsville ontario
My Chicom Husky coil arrived today and I have SPARK. I had to relieve the coil mounting bracket some but it is aluminum so pretty easy to do. I did only work without the kill wire so I will look into that but can always kill with choke. Happy New Year to you all!
 
Hoggwood

Hoggwood

Dumpster saw enthusiast
Joined
Apr 5, 2014
Messages
967
Location
Okanagan, BC
My Chicom Husky coil arrived today and I have SPARK. I had to relieve the coil mounting bracket some but it is aluminum so pretty easy to do. I did only work without the kill wire so I will look into that but can always kill with choke. Happy New Year to you all!
Switch operates in reverse with that setup. Fire on off position and stop on run.
 
fechtichmac

fechtichmac

ArboristSite Operative
Joined
Jan 18, 2012
Messages
244
Location
germany
15x26x7
If my mermory serves me well

Gesendet von meinem SM-G955F mit Tapatalk
15x26x6 will also work fine


Gesendet von meinem SM-G955F mit Tapatalk
 
leecopland

leecopland

Addicted to ArboristSite
Joined
Oct 30, 2011
Messages
1,253
Location
huntsville ontario
If it's not one thing it is another. so after putting it all back together started easily and run OK. Next day it would not start and I broke the recoil spring trying to get it going. I found one on Ebay out of the UK so it's on it's way. Without the recoil it's hard to check to see if some how the coil has failed. I might try to spin it with a drill driver just to eliminate that possibility. I'll press on with the new rings which have arrived from Greece.
 
leecopland

leecopland

Addicted to ArboristSite
Joined
Oct 30, 2011
Messages
1,253
Location
huntsville ontario
So coil is OK, Cabers arrived and are now in the saw. The old rings didn't look too bad so have kept them as back up. Can't check compression without recoil spring so will have to wait.
 
Top