Husqvarna 450 x-torq, help needed

atpchas

atpchas

AtA
Joined
Nov 19, 2007
Messages
3,558
Location
Napa, California
I'm working on a Husky 450 x-torq for a buddy's buddy, so the history is less than ideal. Basic statement of problem I'm seeing: saw starts (reluctantly) but will not run at anything approaching an idle. Things I've done/checked:
1. Tried several different carbs, no appreciable change.
2. New fuel lines and filter - no change,
3. P/V tested (twice) - tight as a drum.
4. Fresh spark plug
5. Compression is about 140 - not great but certainly should be adequate.
6. Rubber manifold between carb and cylinder is sound, no tears or rubber rot.
7. MityVac plugged into impulse tube shows pressure changes when engine is pulled over.
8. Tried all sorts of variations on needles from approx 1 turn out to 3. Shop manual says start at 2 turns on H & L.
9. No scoring evident through muff port or carb ports.

Thanks for any other avenues to pursue before I completely give up on this saw.

P.S. The engineer/designer who thought it would be fun for the carb needle access hole to hide behind the rope handle should be sentenced to eternity trying to make adjustments on such a saw when it requires one hand on throttle to keep it running. AAARRRGH!


Moved to the Chainsaw forum where I meant to post it initially. Senior moments, gotta love 'em.
 
smokey7

smokey7

jack of a lot ace of a few
Joined
Sep 22, 2014
Messages
1,288
Location
Detroit area
Been seeing a quite a few of the limited coils and some on coils with the built in retard/advance. They have issues when making the switch. Try another coil and make sure strato/choke butterfly's work right.
 
atpchas

atpchas

AtA
Joined
Nov 19, 2007
Messages
3,558
Location
Napa, California
Try another coil then.
435-450 modules sometimes failed and still showed spark.
Been seeing a quite a few of the limited coils and some on coils with the built in retard/advance. They have issues when making the switch. Try another coil and make sure strato/choke butterfly's work right.
Just ordered a new Husqvarna coil. My ohm meter shows the primary as an open circuit. Hope this cures what ails it. Will update when the new coil arrives.
 

Latest posts

Top