ArboristSite.com Sponsors
 
 


Husqvarna 44

Discussion in 'Chainsaw' started by kz1000, May 17, 2019.

  1. kz1000

    kz1000 fixumologist

    Joined:
    Jun 16, 2013
    Messages:
    2,376
    Likes Received:
    2,340
    Location:
    Ohio
    Looking for crank seals for a 44, anybody know what fits? None of the sites seem to have the oem. Thanks
     
  2. Huskitoter

    Huskitoter ArboristSite Operative

    Joined:
    Jan 17, 2018
    Messages:
    241
    Likes Received:
    220
    Location:
    Georgia
    kz1000 likes this.
  3. Huskvarna hotellgäst

    Huskvarna hotellgäst ArboristSite Operative

    Joined:
    Feb 14, 2019
    Messages:
    248
    Likes Received:
    176
    Location:
    Australia
    Huskitoter and kz1000 like this.
  4. Huskitoter

    Huskitoter ArboristSite Operative

    Joined:
    Jan 17, 2018
    Messages:
    241
    Likes Received:
    220
    Location:
    Georgia
    Deleted. Looked at bearings instead of seals.
     
  5. Huskvarna hotellgäst

    Huskvarna hotellgäst ArboristSite Operative

    Joined:
    Feb 14, 2019
    Messages:
    248
    Likes Received:
    176
    Location:
    Australia
    May not help but I'm pretty sure 133 & 242 use the same seals.
     
    kz1000 likes this.
  6. kz1000

    kz1000 fixumologist

    Joined:
    Jun 16, 2013
    Messages:
    2,376
    Likes Received:
    2,340
    Location:
    Ohio
    I haven't pulled them yet so don't have any figures. Been fighting the carburetor and think they may be why. Guess I'll vac it to be sure. Thanks.
     
  7. leecopland

    leecopland Addicted to ArboristSite

    Joined:
    Oct 30, 2011
    Messages:
    1,156
    Likes Received:
    404
    Location:
    huntsville ontario
    I have 44 that starts and idles real well but won't rev for S**t it's a HDA carb. Will try soaking in Sea Foam
     
  8. kz1000

    kz1000 fixumologist

    Joined:
    Jun 16, 2013
    Messages:
    2,376
    Likes Received:
    2,340
    Location:
    Ohio
    This one has the hdc and it really wanted to flood bad. I sonic cleaned it and put in a kit but found that the diaphragm had a longer center point, filed it down and it's a whole lot better. Floods on it's side and the l and h are out more than they should be.
     
  9. kz1000

    kz1000 fixumologist

    Joined:
    Jun 16, 2013
    Messages:
    2,376
    Likes Received:
    2,340
    Location:
    Ohio
    I have a hda144a but the primer hole is in a different location.
     
  10. Huskitoter

    Huskitoter ArboristSite Operative

    Joined:
    Jan 17, 2018
    Messages:
    241
    Likes Received:
    220
    Location:
    Georgia
    Sounds like an AM kit. Plenty of those just don't work right, including the one I received where the metal disc was on the wrong side of the diapram.
     
    kz1000 likes this.

Share This Page