ArboristSite.com Sponsors


Jonsered runs for 1 second

rcw3586

rcw3586

ArboristSite Lurker
Joined
Dec 10, 2007
Messages
17
Age
69
Location
Duxbury, MA
I'm pretty knowledgeable about chain saws and have been repairing my own and others for about 20 years. But this problem has be stymied.

The saw is a 2008 Jonsered CS2152C. It's my absolute favorite and gets used all the time in big and small tree jobs. Recently I had been using it for clearing a lot and it had been running perfectly for days. Then one afternoon I picked it up after a short break. It started immediately then stopped in about a second. I tried about 10 times pumping the purge bulb each time with the exact same results before giving up. I checked that it was full of fuel - it was. I got it home and got the same result a dozen more times before taking it all apart.

One thing that bothered me was that when I pumped the purge bulb I heard a whistling sound from the top of the carb near the vent hole in the metering cover and the purge bulb had little resistance. This led me to believe I had a leak in one of the diaphragms. I removed the carb (Zama EL32), took it all apart and inspected it thoroughly. It was squeaky clean and both of the diaphragms and gaskets were totally intact. I blew it out with compressed air to be sure there was no blockage. I did not remove the hi and lo screws since it ran so well when it was running. They probably weren't removable anyway. With the saw completely disassembled (except the crankcase and cylinder) I inspected and tested (using a Mity-Vac) all the fuel and vent hoses for leaks. None were kinked and they all were in pristine condition. The fuel filter and vent valve were clean.
Running out of ideas, I ordered a carb kit and installed its new diaphragms and gaskets a few week later. After cleaning everything up like new and carefully reassembling it, I took it out and started it. It started right up and ran seemingly perfectly as I revved it for about a minute. I restarted it and repeated the test with similar results. FIXED! I declared.

Well, a week later I took it out to a job, went to start it and it behaved exactly as before only running for 1 second at a time repeatedly. Still thinking it was a fuel problem with the pump not working I dismantled the entire path of the impulse passage from crankcase to carb. Everything seemed just perfect with pulses of vacuum and pressure at the bellows bypass hose. The purge bulb now seems to be working perfectly though - no whistling at the metering vent and staying full of fuel. With it all back together again I did a spark test with the plug out and see a nice spark at the plug when pulling the cord. But i have no way of telling if its still sparking at higher RPM. Any thoughts on that? The ignition module was replaced once under warranty early on in life.
It still won't run. I'm hoping someone with similar experience can tell me what I've missed!
Thanks for reading through this!
 
Bob Hedgecutter

Bob Hedgecutter

ArboristSite Guru
Joined
Jul 18, 2019
Messages
766
Location
Small Town, way down South- New Zealand.
Take the spark arrestor screen out of the muffler and check it is not caked solid with carbon.
Take the muffler off and check the condition of the exhaust side of the piston.

Failing that- swap the carb out for a known good on on most any similar sized saw in the Husky/Jonsered family.
 
a. palmer jr.

a. palmer jr.

Tree Freak
Joined
Apr 8, 2007
Messages
13,559
Location
Southern Indiana
I hope you get it fixed, I have a Stihl 021 that does basically the same thing, fires on choke, runs about a second then nothing. It won't hit a lick after that. I can let it sit for a while and do the same thing over and it acts exactly the same way.
 
scottr

scottr

Addicted to ArboristSite
Joined
Nov 18, 2003
Messages
2,462
Location
Alabama
Hey rcw3586 , a PP4218 gave me very similar problems . The fuel filter was partially clogged and the metering diaphram was puckered .
 
Old2stroke

Old2stroke

Never too many toys
Joined
Jan 24, 2016
Messages
512
Age
78
Location
Ottawa, Canada
When a primer bulb sucks air instead of gas, it's often because a main jet check valve is stuck open and the bulb is just sucking air back through it, rather then pulling fuel up the fuel line. These little beggars can drive you nuts as they often become intermittent, it's usually due to alcohol in the fuel causing the little rubber disc inside to become distorted. If it is stuck open, it can bleed air back into the idle circuit and the saw won't run at idle but will run normally at full power if you can get it there. Not sure about that carb, but with a primer bulb in the system there is usually another check valve in the main body of the carb. These check valves are never included in a repair kit but are cheap and can be ordered if you have a parts diagram. Without a parts diagram or pictures it's hard to tell what your carb has, but it will definitely have at least one of these.
 
rcw3586

rcw3586

ArboristSite Lurker
Joined
Dec 10, 2007
Messages
17
Age
69
Location
Duxbury, MA
Old2stroke,
Thank you for your thoughtful reply. The issue you describe matches most closely with the problem described in my post. I think I have pretty much eliminated all the plumbing and other related parts but the inside of the carb is largely inaccessible. I thought all the check valves were handled by flaps on the metering and pump diaphragms which cover various holes to keep the fuel going in the right direction. I did replace those diaphragms but was unaware of any other check valves. I did not remove any welch plugs although the kit I bought did include one or two. I will dig into that again. My next option is to buy a new carb. But i can't afford to just keep replacing parts at random until it works. They are just too expensive.
Thanks again,
Roger
 
Old2stroke

Old2stroke

Never too many toys
Joined
Jan 24, 2016
Messages
512
Age
78
Location
Ottawa, Canada
If you see a small brass fitting (1/4" dia) with a hole in its centre, in the body of the carb where the main fuel pool is, that would be one of the check valves. A main jet check valve usually looks like a solid brass plug under the main jet location and if you have the first one you may not have this one. Both of these are often destroyed by using high pressure air to blow out the carb. A new carb from China is a good approach and here in Canada is a lot cheaper then buying the check valves.
 
rcw3586

rcw3586

ArboristSite Lurker
Joined
Dec 10, 2007
Messages
17
Age
69
Location
Duxbury, MA
Great info! I'll dig into that later and get back to you with the results.
I was looking to buy a carb through partstree.com where they want $62. Is there a recommended on-line place where I can get a quality replacement for lot less money?
Thanks again,
Roger
 
Old2stroke

Old2stroke

Never too many toys
Joined
Jan 24, 2016
Messages
512
Age
78
Location
Ottawa, Canada
There is a simple test for an open check valve. Block the fuel line port to the carb and apply a vacuum to the port that goes to the primer bulb, if it won't hold a vacuum there is a stuck open valve. Test won't help at all if it is just intermittent.
If you search for a carb on ebay, lots will come up from China for less then $10 but the wait time can be more then 4 weeks. Farmertec is a good source for good quality carbs from China. People on this forum will tell you Chinese carbs are nothing but junk, however for the cost I only buy these carbs and have had no serious problems with them, also huztl/Farmertec is usually a lot faster then other carbs from China.

 
a. palmer jr.

a. palmer jr.

Tree Freak
Joined
Apr 8, 2007
Messages
13,559
Location
Southern Indiana
I would be wary of buying any parts from China right now. If you need a carb and want a cheap ebay one buy one that's already in our country, basically the same price, I bought one this week for an 025 and I think it was less than $10 not counting my state's sales tax of 7%.
The reason for saying that is: I ordered some parts from China about 3 or 4 weeks ago and they haven't left their country yet.
 
rcw3586

rcw3586

ArboristSite Lurker
Joined
Dec 10, 2007
Messages
17
Age
69
Location
Duxbury, MA
Old2stroke,
With the carburetor back out I tried your test. Unexpected result! When I applied vacuum to the purge bulb port it held a vacuum whether or not I had the fuel inlet plugged. I could only relieve the vacuum by pushing in on the metering diaphragm through the vent hole. That doesn't seem right at all.

Here is a photo of what's under the metering diaphragm. Perhaps you could educate me on what I'm looking at. I recognize the inlet valve of course but not sure about the brass and silver nozzle-like parts. What's under the welch plugs - just holes?

IMG_6018.JPG
 
rcw3586

rcw3586

ArboristSite Lurker
Joined
Dec 10, 2007
Messages
17
Age
69
Location
Duxbury, MA
Full Disclosure:
After I took it apart to take this photo I reassembled it with the gasket and diaphragm in the wrong order. I ran the vacuum test in that condition first. Then I realized it was backwards and flipped them to the right order before I re-ran the vacuum test with the same result. I do not think that bent the metering lever.
 
Bob Hedgecutter

Bob Hedgecutter

ArboristSite Guru
Joined
Jul 18, 2019
Messages
766
Location
Small Town, way down South- New Zealand.
Full Disclosure:
After I took it apart to take this photo I reassembled it with the gasket and diaphragm in the wrong order. I ran the vacuum test in that condition first. Then I realized it was backwards and flipped them to the right order before I re-ran the vacuum test with the same result. I do not think that bent the metering lever.
Most of us have done that at LEAST once- almost as bad as the Walbro K-24 kit, you get those gaskets mixed up and place the wrong one in the wrong position...... you get the same kind of issues you experienced.
How do I know this? Well I did exactly that just last week!
 
Old2stroke

Old2stroke

Never too many toys
Joined
Jan 24, 2016
Messages
512
Age
78
Location
Ottawa, Canada
In that test with applying a vacuum to the purge port, if the fuel line isn't blocked, the vacuum should open the inlet valve, the fact that it doesn't means that either the inlet valve control lever is set too low or there is something wrong with the diaphragm that operates it. A good reason for an engine not running.
The round brass thing is the body check valve and has to be removed by threading a screw into it and pulling it out, which will destroy it. The other round thing will be the main jet check valve but with the hole in it, it isn't a normal looking one. They can usually be punched out into the throat of the carb and repaired, then pressed back in, but as I said it isn't a common looking one. The long welch-ish plug will be covering the idle and transfer ports, and the other one probably covers fuel passages from the body check valve to the idle circuit.
 
rcw3586

rcw3586

ArboristSite Lurker
Joined
Dec 10, 2007
Messages
17
Age
69
Location
Duxbury, MA
I tried to pull out the check valve with pliers but just ended up buggering it up. I found a video on line on how to test it with the vacuum pump and lots on pressure testing of the inlet valve thanks to PV Hiker. I've learned a lot about it thanks to you guys. But, in the end, I've ordered a new ZAMA carb from ebay for $42 which I will have Monday. Unfortunately, on the huztl/Farmertec site I could not find my model. I'll let you all know how I make out with that. Thanks!
 
Top