ArboristSite.com Sponsors
 
 


  1. Please see this post Click Here Please ask questions if you have them!! I hope this is going to be great for us all.
    Dismiss Notice

New thermostat now no heat?

Discussion in 'Reader's Rides' started by Flint Mitch, Nov 4, 2018.

  1. Flint Mitch

    Flint Mitch ArboristSite Operative

    Joined:
    Apr 22, 2016
    Messages:
    459
    Likes Received:
    748
    Location:
    US
    Had the thermostat in my 2011 impala (3.5l) take a crap. Just changed it out and now I have no heat. What the hell went wrong?

    Sent from my SM-G892A using Tapatalk
     
  2. 95custmz

    95custmz ArboristSite Guru

    Joined:
    Jun 18, 2014
    Messages:
    687
    Likes Received:
    2,230
    Location:
    Plainfield, IN
    Have you checked out your heater core? Or possibly, you got a bad thermostat. Put it in boiling water to make sure it is opening & closing.


    Sent from my iPhone using Tapatalk
     
    Flint Mitch likes this.
  3. ChoppyChoppy

    ChoppyChoppy Addicted to ArboristSite

    Joined:
    Jun 17, 2013
    Messages:
    8,809
    Likes Received:
    8,120
    Location:
    AK
    Did you bleed the air from the cooling system?
     
    95custmz and Flint Mitch like this.
  4. Flint Mitch

    Flint Mitch ArboristSite Operative

    Joined:
    Apr 22, 2016
    Messages:
    459
    Likes Received:
    748
    Location:
    US
    It was an air pocket. All is good!

    Sent from my SM-G892A using Tapatalk
     
    95custmz likes this.

Share This Page